The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

adblock crashes mozilla at usps site

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
jeffw_00



Joined: 21 Oct 2004
Posts: 6

PostPosted: Thu Apr 21, 2005    Post subject: adblock crashes mozilla at usps site Reply with quote

1) goto usps.com
2) select "click and ship"
3) select (at bottom right" print a sample label.
4) (with adblock installed) watch Mozilla hang...

would be really nice if you could fix this - I love adblock, but need to use this site.

THANKS!
/j
Back to top
View user's profile Send private message
Dave
Guest





PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

I just performed the steps that you described and Mozilla did not crash. The page does appear to require Java to be of any use, and I do not use Java.

How did you determine that adblock was the source of the problem? What version of Mozilla are you using? Is it the latest release version?
Back to top
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

If you have Java 1.4.x please upgrade it to 1.5 which works much better.

The site has been mentioned earlier:
http://aasted.org/adblock/viewtopic.php?t=740

Get the latest Java here:
http://www.java.com
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
Guest






PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Guys - if you go to the page

https://sss-web.usps.com/ds/jsps/ds_landing.jsp

and at the bottom right select "the "GO" under "Print a Sample Label". it WILL start a JAVA application. I can selectively make it work or fail by uninstalling and re-installing adblock 0.5 (with no other extensions installed). I'm not trying to dis adblock, which I think is a great tool, but I think you can see why I think the problem lies here. It happens with Java 1.4 and 1.5 (the only two I've tried, could be others), and I suspect isn't a Java thing at all but
somehow Adblock is interfering with the Java script.

Any suggestions on how to fix would be very appreciated.

Thanks
/j
Back to top
Guest






PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

sorry - didn't answer everyone - I'm using Moz 1.7.7, though I have observed this since 1.7.1
Back to top
Zachariah



Joined: 21 Jul 2004
Posts: 703
Location: Earth

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Anonymous wrote:
It happens with Java 1.4 and 1.5 (the only two I've tried, could be others), and I suspect isn't a Java thing at all but
somehow Adblock is interfering with the Java


WFM

I'm using: Mozilla 1.7.5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

I have adblock installed, and the latest versrion of Java (JRE 5.0 Update 2 - offline installer)

I tried the page with obj-tags on and off, no difference

I cannot get Mozilla to crash.



As for your theory that this is a bug in Adblock and "isn't a Java thing at all", there have been previous cases where bugs in Java were revealed by Adblock, but not caused by it. You could even be revealing a known Java bug right now with Adblock -- but that doesn't make it an Adblock bug.

But, you could also be discovering an Adblock bug.

The really strange part is that no one else (so far (unless guest isn't jefw_00)) can reproduce the crash
_________________
Latest Adblock!

If all else fails try a really fresh install of Firefox
.


Last edited by Zachariah on Thu Apr 21, 2005; edited 1 time in total
Back to top
View user's profile Send private message
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Adblock does indeed cause problems with certain Java applets. This is a very old and well known bug. Unfortunately no one knows what is causing it, or if it is indeed a bug in Adblock, Firefox, or Sun's Java VM. The latest Java 1.5 works better than the older 1.4.x, but it still does not work everywhere.
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
Org



Joined: 23 Oct 2003
Posts: 349

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

I wonder if the Java people of Sun would investigate this if someone asked nicely?
Back to top
View user's profile Send private message
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Fri Apr 22, 2005    Post subject: Reply with quote

Good question. You volunteering for emailing them? Smile
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
jeffw_00



Joined: 21 Oct 2004
Posts: 6

PostPosted: Sat Apr 23, 2005    Post subject: Reply with quote

my apologies because
1) i did post as guest accidently
2) with the newest java, it appears to work (though it takes a long time to load the applet the first time...)

thanks guys
/j
Back to top
View user's profile Send private message
saber850
Guest





PostPosted: Wed Apr 27, 2005    Post subject: Applet problems Reply with quote

Hi all,

I'm experiencing a problem where AdBlock is causing my Java Applet to load twice on the same page.

The symptoms of the applet loading twice:
    - Applet callbacks (init, start, stop) are all called twice (as seen via print statements in the java console)
    - The resulting GUI has two instances (ie. the login dialog and app frame are presented twice).

The symptoms of AdBlock being related to the problem:
    - the problem only occurs when AdBlock is enabled. Disabling AdBlock (via Firefox's control, I haven't tried AdBlock's control on the settings panel) causes the Applet to load properly (ie. only once).


I've verified this behavior on these systems:
    - x86; Gentoo Linux; Sun Java 1.4.2_07
    - x86; Windows XP; Sun Java 1.4.2_06
    - x86; Windows XP; Sun Java 1.5.0_02


Since this is my code, I'm open to any testing/debugging suggestions. For instance, I can print trace and debug statements from the Applet.

If requested, I'll post the URL to the Applet.

Thanks.
Back to top
saber850
Guest





PostPosted: Wed Apr 27, 2005    Post subject: Reply with quote

Oops, forgot some additional specs:

Both systems (Linux & Windows) are running:
AdBlock version: 0.5.2.039
Firefox: 1.0.3

I also forgot the most important thing:
Thanks for a spectacular extension!
Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group