The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

BUG REPORT: adblock changes layout while blocking nothing

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Mon Apr 11, 2005    Post subject: BUG REPORT: adblock changes layout while blocking nothing Reply with quote

I've posted on this subject before, but we really got nowhere. Possibly this time we can actually get somewhere with this. I would really hate to see the next version being released while it still shows such erratic behavior. Adblock is way too cool for me to let that happen. Wink

See: http://www.[out-of-date].com/index.html

Without Adblock installed the tabs hang down from the image as expected.
With Adblock enabled in the extension window (no matter if it's enabled in the Adblock preferences) it messes up the design, one of the tabs hangs below the other.

I've verified this on two different computers and with one PortableFirefox on USB no matter on what computer. All have differnt rules. This does not occur when the files are loaded from a local hdd (file:///...).

I've created this testcase which includes a screenshot:
http://www.[out-of-date].com/testcases/adblock

devs... please let me know what you make of this. Thanks for such a great extension!


Last edited by imforumman on Fri Apr 07, 2006; edited 1 time in total
Back to top
View user's profile Send private message
valentyn



Joined: 11 Apr 2005
Posts: 2
Location: amsterdam, the netherlands

PostPosted: Tue Apr 12, 2005    Post subject: Ack, and other test case Reply with quote

Hi, as posted in http://aasted.org/adblock/viewtopic.php?t=1813 I encountered this problem, too. http://www.iriver.com/html/support/download/sudw_list.asp shows no list with Adblock installed. (It's a site with Quirks mode rendering, so one shouldn't be surprised, but Adblock shouldn't change the rendering).
_________________
my other .sig is a 500 page novel
Back to top
View user's profile Send private message Send e-mail Visit poster's website
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Tue Apr 12, 2005    Post subject: Reply with quote

Hmm. Both the pages fail to render properly in 0.6 too. Interesting.
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Tue Apr 12, 2005    Post subject: Reply with quote

kstahl,

I'm glad I've gotten your attention. If you can use any help with testcases etc please let me know.

Thanks and keep it up!
Back to top
View user's profile Send private message
wonkothesane
The Other Developer


Joined: 22 May 2004
Posts: 210

PostPosted: Wed Apr 13, 2005    Post subject: Reply with quote

Even more interesting: my 0.6 seems to do just fine for both pages.

Most strange indeed.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Thu Apr 21, 2005    Post subject: Fixed by Fx 1.0.3 Reply with quote

Hey dev's... can you confirm that this has been fixed by Fx 1.0.3?

All of a sudden I'm not able to reproduce this anymore, and I can only make out the switch to 1.0.3 as the reason...

Please confirm!
Thx!
Back to top
View user's profile Send private message
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Using a second system I've just confirmed that the upgrade to 1.0.3 fixes this.

Sorry about ever blaming AdBlock... keep it up!!!
Back to top
View user's profile Send private message
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Still broken in Firefox 1.0.3, searching does not produce any results.

From the JS Console:

Error: obj.SetVariable is not a function
Source File: http://www.iriver.com/common/js/flashlink.js
Line: 11
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

OK, the iriver site is still broken, yea, but the testcase I posted is WFM with 1.0.3 and adblock b39. Can you confirm this? If you can't, then this is some really hard to reproduce effect, as was already hinted at by wonkothesane.
Back to top
View user's profile Send private message
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Sorry, I only tested the iRiver site. Yes, your test case appears to be fixed in Firefox 1.0.3. Obviously, Adblock exposed a bug in the Gecko rendering engine.
_________________
Adblock 0.5.3.042
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.Cool Gecko/20051111 Firefox/1.5
Back to top
View user's profile Send private message
imforumman



Joined: 11 Nov 2004
Posts: 10

PostPosted: Thu Apr 21, 2005    Post subject: Reply with quote

Ok, I'm thnking the iriver problem is not an adblock thing and probably not even a problem in gecko:

Go to the above url, hit shift-reload. No drivers are shown. Any action now causes the drivers to be shown: (regular) reload, selecting a product and "go", etc.

Anyway, what I thought was bug in adblock wasn't, and my site is fixed... so I guess I'll be back if I ever have doubts about adblock again.

Guys, thank you very much for this superb extension: and don't make it work 100% out-of-the-box, I very much enjoy seeing the before-and-after effect. Wink Keep it up!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group