The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

adblock doesn't work

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
xeen
Guest





PostPosted: Thu Nov 20, 2003    Post subject: adblock doesn't work Reply with quote

first of all: your plugins is great Very Happy

ok i saw that a new version came out euh.. i don't know when it came out.
Well i wanted to update to newer version which didin't work because of the old one. Deactivating in Perfences didn'T work too, so i deinstalled myself.

Startet Firebird - worked.
I installed 0.5d and it said "restart browser so activate".
I did and I got the following error Message (sorry its in German i don't know hwts that in english Sad)

"Der Prozedureinsprungspunkt "NS_NewArrayEnumerator" wurde in der DLL "xpcom.dll" nicht gefunden". Which means that the... eh.. "function" NS_NewArrayEnumerator wasn't found in the "xpcom.dll"

I don't know what to do, because its the normal dll coming along with firebird package. I just get this err msg after installing (adblock), any other restart won't produce this. Adblock is listed under Plugins, activating deactivating works, but it doesn't matter.

any ideas?

thx for your help
xeen
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Thu Nov 20, 2003    Post subject: Reply with quote

xeen:
The only thing that occurs to me is: you didn't properly deinstall v.3.
.
Were you following directions from either the forum (here) or faq-page?
.
If it's a profile-install, this can be easily tested by making a new one. If it's root, you may want to reinstall your browser.
Back to top
View user's profile Send private message
Guest






PostPosted: Fri Nov 21, 2003    Post subject: Reply with quote

i think i deinstalled the older version correctly.
I saw the FAQ after deinstalling, but i searched for every text with "adblock" and removed everything which had to do with "adblock".

so if i want v5 getting to work i must deinstall v5 and then reinstall...
ok i'll try
Back to top
xeen
Guest





PostPosted: Fri Nov 21, 2003    Post subject: Reply with quote

ha! i got it. well almost.
I opened the installed-chrome.txt and noticed that the last line was corrupted, well it was different from every line elsewhere in this file.
I removed it and restartet. Adblock works now but Browser is in english (i dunno how that could happen) and IE-View the plugin which corrupted the file.

I'll reinstall IE View, i think it'll work then, the browser in english...well it would be nice if i can get it back in german without reinstalling everything but the english version is not that bad because the menus aren't as long as the german ones.

so everyone who thinks he deinstalled adblock right and it still doenst work should have a look at installed-chrome.txt Wink
xeen
Back to top
hank



Joined: 15 Nov 2003
Posts: 58

PostPosted: Sat Nov 22, 2003    Post subject: Nope .... OSX, Adblock 18: Firebird Prefs sees it, Tools no Reply with quote

Had Adblock v17. Deinstalled it, stopped and restarted Firebird, went here, installed V18 OK. Stopped and restarted Firebird. No mention of Adblock in Tools menu. Firebird Prefs sees it, will enable and disable it -- but it never shows up in Tools or on the screen.

I'm using the latest (as of an hour ago) Firebird, Mac OSX 10.2.8.

I did try removing my other extensions and of course rebooting the Mac.

Nope. And of course I can't deinstall it since it's not there, but can't reinstall it since it is there.

Nor does the file you named appear to exist, at least under Mac OSX. Any other possible names for it?

Does this error message help?

[Exception..."ContentLength not available (not a local URL?)' when calling method:
[nsIModule::getClassObject]" nsresult: "0x8057001e(NS_ERROR_XPC_JS_THREW_STRING)"
?<unknown>" data:no]
Back to top
View user's profile Send private message
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

hank:
Did you install to profile, or root?
.
Locate your profile directory and look for a file with "xul" in its name. Delete it. Open the chrome subdirectory and post here a listing of its contents.
.
Next, open the application folder, and its chrome subdirectory. Remove the file "chrome.rdf" and the directory "overlayinfo". Post here a listing of the remaining contents.
.
Recap: I need to know where you installed, and what's in your two chrome directories.
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

OK. I hope someone else using OSX can verify what I'm reporting, in case there are files missing or misplaced -- I don't know that what I have is right for OSX, nothing to compare to.
It certainly isn't what the Firebird developers expect for file locations!


The files you asked for are Installed in

Bin/Users/hank/Library/Phoenix/Profiles/Hank User/5274hqz0.sit/ (the Users directory is on a volume named /Bin, with a symlink in the boot drive's root directory).

I found: XUL.mfast there and deleted it just now. (I'll have to restart before Firebird quits using it, however). I'll do that once I post this.

The application is in Macintosh/Applications/Firebird --"Macintosh" is the OSX boot drive. There are no subdirectories under /Firebird. (I created the directory because I read often that Firebird requires one -- but OSX rarely puts apps in directories, they go in /Applications though they work OK in subdirectories there (I think, I hope).


There is only one directory named Chrome -- not with the application:

/Chrome exists only under
/Users/hank/Library/Phoenix/Profiles/Hank User/5274hqz0.sit/

There is no file -- anywhere -- named
chrome.rdf
There is no file -- anywhere -- containing "overlay" in the name.

There are files under
/Users/hank/Library/Phoenix/Profiles/Hank User/5274hqz0.sit/ Chrome/ named:
downloads.rdf
localstore.rdf
mimetypes.rdf
panels.rdf
search.rdf

There are:
/Library/Mozilla/ containing Global.regs and Versions.regs

There is a /Users/hank/Library/Preferences/org.mozilla.mozilla.plist--recent timestamp.

There is (any chance this would confuse anything?) a file named Phoenix under /America down under the JavaVM.framework -- files for major cities, shouldn't be confusing anything.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

hank:
Try browsing Firebird's package contents: right-click the .app-file and select "Show Package Contents". Do you see the app-chrome directory?
.
Also, did you install Adblock to profile, or root?
Back to top
View user's profile Send private message
hank



Joined: 15 Nov 2003
Posts: 58

PostPosted: Sat Nov 22, 2003    Post subject: better --- installed in Profile; contents of package ... Reply with quote

OK! Yes, I installed in the Profile (always so as not to need to reinstall wh en getting the new daily version of Firebird).

Contents of the Firebird package after I
removed chrome.rdf and the overlay directory.
/CVS
/Entries
/Repository
/Root
/MacOS/Chrome:
/browser (subfolders empty, size is zero)
browser.jar
chromelist.txt
/classic (subfolders empty, size is zero)
classic.jar
/comm (subfolder empty, size is zero)
comm.jar
/embed-sample (subfolders empty, size is zero)
embed-sample.jar
/en-mac (subfolder empty, size is zero)
en-mac.jar
/en-unix (empty)
en-unix.jar
/en-US (subfolder empty, size is zero)
en-US.jar
/en-win (subfolder empty, size is zero)
en-win.jar
/inspector (subfolders empty, size is zero)
inspector.jar
installed-chrome.txt
/modern (subfolders empty, size is zero)
modern.jar
/pipnss (subfolders empty, size is zero)
pipnss.jar
/pippki (subfolders empty, size is zero)
pippki.jar
/toolkit (subfolder empty, size is zero)
ttoolkit.jar
/US (subfolders empty, size is zero)
us.jar

Let me try that in the terminal instead of typing it.


Last edited by hank on Sat Nov 22, 2003; edited 1 time in total
Back to top
View user's profile Send private message
hank



Joined: 15 Nov 2003
Posts: 58

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

OK, I figured, heck, I could do this on a VAX 750, I should be able to do it on a Macintosh. The files I'd deleted were recreated when I restarted.
Inside Firebird's /MacOS/Chrome/ are
864 -rw-r--r-- 1 hank admin 441225 Nov 21 20:54 en-US.jar
1576 -rw-r--r-- 1 hank admin 804672 Nov 21 20:41 classic.jar
8 -rw-r--r-- 1 hank admin 3904 Nov 21 20:40 installed-chrome.txt
2000 -rw-r--r-- 1 hank admin 1021478 Nov 21 20:40 toolkit.jar
1552 -rw-r--r-- 1 hank admin 790856 Nov 21 20:40 browser.jar
16 -rw-r--r-- 1 hank admin 6815 Nov 21 20:40 en-mac.jar
24 -rw-r--r-- 1 hank admin 10840 Nov 21 20:40 US.jar
48 -rw-r--r-- 1 hank admin 23154 Nov 21 20:40 chrome.rdf
3128 -rw-r--r-- 1 hank admin 1598331 Nov 21 20:40 comm.jar
48 -rw-r--r-- 1 hank admin 23230 Nov 21 20:40 embed-sample.jar
1072 -rw-r--r-- 1 hank admin 545941 Nov 21 20:40 inspector.jar
0 drwxr-xr-x 7 hank admin 238 Nov 21 20:40 overlayinfo
8 -rw-r--r-- 1 hank admin 748 Nov 21 20:40 pipnss.jar
536 -rw-r--r-- 1 hank admin 272748 Nov 21 20:40 pippki.jar
16 -rwxrwxrwx 1 hank admin 6148 Nov 21 19:42 .DS_Store
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 US
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 browser
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 classic
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 comm
0 drwxrwxrwx 5 hank admin 170 Nov 21 18:44 embed-sample
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 en-US
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 en-mac
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 en-unix
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 en-win
0 drwxrwxrwx 5 hank admin 170 Nov 21 18:44 inspector
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 modern
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 pipnss
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 pippki
0 drwxrwxrwx 3 hank admin 102 Nov 21 18:44 toolkit
376 -rw-r--r-- 1 hank admin 191471 Nov 21 14:43 chromelist.txt
16 -rw-r--r-- 1 hank admin 7002 Nov 21 14:43 en-unix.jar
16 -rw-r--r-- 1 hank admin 7606 Nov 21 14:43 en-win.jar
8 -rw-r--r-- 1 hank admin 2913 Nov 21 14:43 modern.jar
Back to top
View user's profile Send private message
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

hank:
If removing the cache and resetting your overlay-registry didn't fix things, try the new "live-install" in d2 nightly 19.
.
I'm not sure how well it plays across platforms, but the installer now removes your previous version for you. To upgrade, you no longer need to deinstall first.
Back to top
View user's profile Send private message
hank



Joined: 15 Nov 2003
Posts: 58

PostPosted: Sat Nov 22, 2003    Post subject: OK so far, doing those things did ... Reply with quote

Following the instructions above did remove (all of) the extensions, and after that I was able to reinstall Adblock 18 -- but i'm very glad to hear about v19.

Thanks!
Back to top
View user's profile Send private message
jiro



Joined: 22 Nov 2003
Posts: 7

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

rue wrote:

If removing the cache and resetting your overlay-registry didn't fix things, try the new "live-install" in d2 nightly 19.
.
I'm not sure how well it plays across platforms, but the installer now removes your previous version for you. To upgrade, you no longer need to deinstall first.


d2 v19 works sweet! but it does not install on top of previous versions. I got an error message when i tried. (winXP pro, firebird 0.7)

instead, i successfully installed it by:
1. deinstalling d2 v17 using the deinstall button in preferences
2. disabling adblock in the firebird extensions menu
3. installing d2 v19.

all in all, a big improvement over manually deleting/editing config files. good job!
Back to top
View user's profile Send private message
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

jiro:
If you open the install-log (in your application-dir), you can see what went wrong during any install.
.
Could you post the report for the failed "live-install"?
Back to top
View user's profile Send private message
jiro



Joined: 22 Nov 2003
Posts: 7

PostPosted: Sat Nov 22, 2003    Post subject: Reply with quote

rue,

the install log is listed below. note that the second, successful install occurred after did a deinstall and and then disabled the extension. also I am not positive that both the deinstall and disable steps were necessary - maybe it would be sufficient to disable the preexisting version of adblock, so then winXP wouldn't identify the adblock.jar file as being "in use"


-------------------------------------------------------------------------------
http://adblock.mozdev.org/adblock-0.5-dev.xpi -- 11/22/2003 13:27:16
-------------------------------------------------------------------------------

pre-install (version 0.0)
-----------

[1/1] Create Folder: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.0)
-----------

[1/1]
pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

[1/1]
adblock (version 0.5)
-------


Install cancelled by script -- 11/22/2003 13:27:32

-------------------------------------------------------------------------------
http://adblock.mozdev.org/adblock-0.5-dev.xpi -- 11/22/2003 13:28:46
-------------------------------------------------------------------------------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

[1/1]
pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

[1/1]
adblock (version 0.5)
-------

[1/2] Installing: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock.jar
[2/2] Register Content: jar:file:///C:/DOCUMENTS%20AND%20SETTINGS/JONATHAN/APPLICATION%20DATA/Phoenix/Profiles/default/pcnuxz6d.slt/chrome/adblock.jar!/content/

Install completed successfully -- 11/22/2003 13:28:50
Back to top
View user's profile Send private message
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sun Nov 23, 2003    Post subject: Reply with quote

jiro:
I modified the installer some more. If you wouldn't mind: try "live-installing" again, and post the result-log. Also, post a summary of the error message. I have a pretty good idea what it is, but I'd like to be sure.
Back to top
View user's profile Send private message
jiro



Joined: 22 Nov 2003
Posts: 7

PostPosted: Thu Nov 27, 2003    Post subject: Reply with quote

rue,

install log listed below. basically, first installation attempt failed giving an error -23. i then deinstalled the previous version of adblock using the deinstall button, and then installed the updated version (v20) successfully. no need to manually mess with files, just a two step deinstall/install procedure.

jiro

-------------------------------------------------------------------------------
http://adblock.mozdev.org/adblock-0.5-dev.xpi -- 11/26/2003 20:47:02
-------------------------------------------------------------------------------

pre-install (version 0.0)
-----------

[1/1] Create Folder: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.0)
-----------

[1/1]
pre-install (version 0.0)
-----------

** ERROR (-232): Move File: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-uninstalled to C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.0)
-----------

pre-install (version 0.1)
-----------

pre-install (version 0.2)
-----------

pre-install (version 0.3)
-----------

pre-install (version 0.4)
-----------

pre-install (version 0.5)
-----------

pre-install (version 0.6)
-----------

[1/1]
pre-install (version 0.6)
-----------

[1/1] Move File: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\adblock-uninstalled to C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.6)
-----------

adblock (version 0.5)
-------


Install **FAILED** with error -23 -- 11/26/2003 20:47:11

-------------------------------------------------------------------------------
http://adblock.mozdev.org/adblock-0.5-dev.xpi -- 11/26/2003 20:48:21
-------------------------------------------------------------------------------

pre-install (version 0.0)
-----------

pre-install (version 0.0)
-----------

[1/1]
pre-install (version 0.0)
-----------

[1/1] Move File: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-uninstalled to C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.0)
-----------

pre-install (version 0.1)
-----------

pre-install (version 0.2)
-----------

pre-install (version 0.3)
-----------

pre-install (version 0.4)
-----------

pre-install (version 0.5)
-----------

pre-install (version 0.6)
-----------

[1/1]
pre-install (version 0.6)
-----------

[1/1] Move File: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\adblock-uninstalled to C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock-temp
pre-install (version 0.6)
-----------

adblock (version 0.5)
-------

[1/2] Installing: C:\DOCUMENTS AND SETTINGS\JONATHAN\APPLICATION DATA\Phoenix\Profiles\default\pcnuxz6d.slt\chrome\adblock.jar
[2/2] Register Content: jar:file:///C:/DOCUMENTS%20AND%20SETTINGS/JONATHAN/APPLICATION%20DATA/Phoenix/Profiles/default/pcnuxz6d.slt/chrome/adblock.jar!/content/

Install completed successfully -- 11/26/2003 20:48:29
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group