The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

some websites broken by AdBlock

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
Rafael S
Guest





PostPosted: Tue Dec 13, 2005    Post subject: some websites broken by AdBlock Reply with quote

Hello

I don't know if this is the right place to report this, but I have a couple of websites whose appearance are broken by AdBlock. Both them appear wrongly simply by the presence of the extension in Firefox, ie, disabling it won't change anything. Same happens for AdBlockPlus.
websites:

http://www.redemet.aer.mil.br/
(adblock makes site appear in a small box)

http://www.clicrbs.com.br
(choose option 'clicNoticias' in left menu, whole site will appear displaced almost a screen to the right)

Thanks a lot. If this isn't the right place to report these bugs, please tell me how to do it.

Rafael
Back to top
rick75
Guest





PostPosted: Thu Dec 15, 2005    Post subject: Both sites screwed up Reply with quote

The first site has very bad code ... mixed and missing closure tags. Most closing FONT tags are missing. The site is a code disaster.

The 2nd site just comes up with an error with Adblock OFF.

These are NOT Adblock problems ... they are just badly made sites.
Back to top
Rafael S
Guest





PostPosted: Thu Dec 15, 2005    Post subject: Reply with quote

I know it and agree 100% with you. But both these sites, even being crappily coded, appear OK in Firefox w/o Adblock. I kind of hoped they would appear the same way with Adblock. Or at least with Adblock inactive.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Thu Dec 15, 2005    Post subject: Reply with quote

Rafael:
The first site fails without Adblock. If you clear your cache (Firefox Preferences> Content> Cache) you'll see it fail on reload. Since when cached it works, the issue looks timing/reflow-queue related.
.
The second site uses css-positioning, which assumes the blocked ad-banners are present. It's hard-coded.
.
Both issues are interesting, but not ours to solve.
Back to top
View user's profile Send private message
Rafael S
Guest





PostPosted: Thu Dec 15, 2005    Post subject: Reply with quote

Thanks for the quick reply, rue.
For the first site, I noticed the fact that it worked when cached. But for some reason I assumed it would be related to being cached in memory, not in disk. Then, when I uninstalled Adblock, restarted and tried the page again, it worked. My fault, sorry.
As for the second site, I suspected it might have had issues because sometimes it works correctly - perhaps when they change the layout to a slightly different appearance, because of occasional events advertised in the banners. But this one I am sure I had checked with Adblock on and off, reloading the page with ctrl+F5. I am pretty sure I was using one of the unofficial versions and if I'm not mistaken there was one when activating or deactivating Adblock had no effect (at least in my system). But now I checked once again (with full cache flushing) and it worked. Once again, sorry...

Rafael
Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group