The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Frame Blocking Problems

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Fri Dec 12, 2003    Post subject: Reply with quote

rue wrote:
NJH:
/[\W\d]ad(serv(er|e)?|s|v)?[\W\d]/


Hello, when i'm using your pattern above, try this http://www.detik.com

it goes blank.... Sad

But on your previous build, (i forget which build Smile ) it's okay, Adblock blocks [url]]http://www.detik.com/adv/*[/url] because that regex pattern above...

BTW, i'm using build 31, on Linux Debian Unstable.... only obj-tabs activated
On Adblock-able items, http://ad.detik.com and http://www.detik.com/adv/ it's blocked by Adblock. But the subdocument http://www.detik.com/index.htm (FRAME) didn't show up...

TIA

jef198
jefree
Back to top
Guest






PostPosted: Fri Dec 12, 2003    Post subject: Reply with quote

I have not had any problems with the filter, but only because I have not visited any sites where /adv/ is not an advertisment. Clearly you will have to tailor the filter to your own requirements. This is one problem of these big filters. They can give false positives. Try removing the |v from the filter and see if it then lets undesirable ads.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Fri Dec 12, 2003    Post subject: Reply with quote

No- there's a serious bug with frame-blocking; and I don't think it's Adblock's fault.
.
What it looks like so far: with nested framesets, when a frame is blocked, the browser loses its place and tries to load the same frame with the next frame's url. Adblock says "go ahead and load".. except the frame in question isn't loading -- its sibling is. And thus, the sibling never loads.
.
So far, my patches have only sent it into a weird recursion-loop. But, I'm not done yet...
Back to top
View user's profile Send private message
Guest






PostPosted: Wed Dec 31, 2003    Post subject: Reply with quote

rue wrote:
No- there's a serious bug with frame-blocking; and I don't think it's Adblock's fault.
.


OK. It's mozilla's 1.5.3 fault. I haven't tried mozilla 1.6b yet. But on firebird 0.7 Windows platform, it's okay.... Surprised

Rue, would you mind to post this bug on bugzilla?

Thanks for this tools... it's cool : Shock
no more ads Very Happy

TIA

Jefree
jef198
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Wed Dec 31, 2003    Post subject: Reply with quote

jef:
Hey- I forgot this thread. The issue was fixed back for nightly 32.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group