The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

gmail problems

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
zepnation
Guest





PostPosted: Fri Aug 05, 2005    Post subject: gmail problems Reply with quote

hi, first of all you guys are saviours, your project is very concomitant with the clean and hasslefree internet experience that defines firefox, keep up the good work....

presently i am using "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.Cool Gecko/20050511 Firefox/1.0.4" and use the extension gmail notifier ver 0.5.0 of late adblock plus 0.5.9 is blocking my logon! the logon page loads but even after whitelisting "mail.google.com" it is not helping my cause!

basically its blocking the script
"https://mail.google.com/mail/?view=page&name=browser&ver=c0d3d44c64799453"

hope you can help Smile

i also use extension "noscript1.1.1" but is set to allow all javascript on the setting "javascript currently allowed [<script >:2][J+F+P:0]"

thank you
Back to top
mcm_ham



Joined: 17 Dec 2004
Posts: 310

PostPosted: Fri Aug 05, 2005    Post subject: Reply with quote

Are you sure it's an extension at fault, Gmail's login has been playing up lately.
Back to top
View user's profile Send private message Visit poster's website
anon
Guest





PostPosted: Fri Aug 05, 2005    Post subject: re: gmail Reply with quote

I was getting hung up on the "Loading..." window. After much trial and error I found that if I changed Adblockfrom "Remove ads" to "hide ads" it worked OK. Before that switch I was getting a Javascript exception along the lines of:

Error: uncaught exception: [Exception... "Component returned failure code: 0x805e000a [nsIDOMLocation.replace]" nsresult: "0x805e000a (<unknown>)" location: "JS frame :: https://mail.google.com/mail/ :: lj :: line 3" data: no]

thx
jeff
Back to top
zepnation
Guest





PostPosted: Fri Aug 05, 2005    Post subject: still no love Reply with quote

mcm_ham, my gmail login and the notifier are working fit as a fiddle,touch wood :P(its working fine with adblock disabled)

jeff, i am not so computer savvy, so if you would kindly explain in detail how i move the "hide ads" mode. i tried fishing for the option in preferences but couldn't find it :(
with the "enable adhiding" in the support website section, when activated the number of blockable items increases manifold which includes div,subdocument and image, wherein earlier it was just script!

i hope i don't need to reinstall the
Back to top
anon
Guest





PostPosted: Sat Aug 06, 2005    Post subject: Re: still no love Reply with quote

zepnation wrote:
mcm_ham, my gmail login and the notifier are working fit as a fiddle,touch wood Razz(its working fine with adblock disabled)

jeff, i am not so computer savvy, so if you would kindly explain in detail how i move the "hide ads" mode. i tried fishing for the option in preferences but couldn't find it Sad
with the "enable adhiding" in the support website section, when activated the number of blockable items increases manifold which includes div,subdocument and image, wherein earlier it was just script!

i hope i don't need to reinstall the


I'm using Adblock v0.5 d2 nightly * build 39 and FF 1.0.6 on a Win2K machine. Assuming we're on roughly the same page:

Tools>Adblock>Preferences - in the lower left of the dialog are 2 radio buttons - Hide and Remove. You should be able to take it from there.

jeff
Back to top
zepnation
Guest





PostPosted: Sat Aug 06, 2005    Post subject: thx for reply Reply with quote

jeff, thx for replying ..

i am using the adblock plus ver 0.5.9 on os platform winxp sp2 . unfortuantely the radio buttons when activated increase by a guzillions the items which can be blocked on gmail login(from just script with the radio button off to include script,subdocument,image and div when switched on), ref. the earlier msg

tell me if you need more info, and much appreciate your help Smile

thx
abhinav
Back to top
anon
Guest





PostPosted: Wed Aug 10, 2005    Post subject: Re: thx for reply Reply with quote

zepnation wrote:
jeff, thx for replying ..

i am using the adblock plus ver 0.5.9 on os platform winxp sp2 . unfortuantely the radio buttons when activated increase by a guzillions the items which can be blocked on gmail login(from just script with the radio button off to include script,subdocument,image and div when switched on), ref. the earlier msg

tell me if you need more info, and much appreciate your help Smile

thx
abhinav


Sorry, I'm not much help beyond that. I've been writing software for closing in on 27 years, but as far as Firefox goes I'm just another "better educated than average" user. Still learning. Hell, I just started tinkering with userChrome.css last week Shock

As an educated guess, though, in my case I think the problem might be stemming from the regexp lines in my Adblock list. My machines at home are an XP Home and XP Pro (both SP2) which do not have the same Adblock list as my Win2K laptop *and* do not suffer from the gmail problem. All they have for blockings are wildcards like "site/directory/*" whereas my Win2K list includes some more advanced expressions that I lifted from somewhere:
/\D\d{2,3}x\d{2,3}\D/
/\/buy_assets\//
/[\W\d_](top|bottom|left|right|)?banner(s|id=|\d|_)[\W\d]/
/[\W\d](double|fast)click[\W\d]/
/[\W\d]click(stream|thrutraffic|thru|xchange)[\W\d]/
/[\W\d]value(stream|xchange|click)[\W\d]/
/[\W\d]dime(xchange|click)[\W\d]/
/[\W\d](onlineads?|ad(banner|click|-?flow|frame|ima?g(es?)?|_id|js|log|serv(er|e)?|stream|_string|s|trix|type|vertisements?|v|vert|xchange)?)[\W\d]/

If I was more diligent and had the time to spare I'd get into removing the regexp lines one-by-one to see which (if any) are the culprit.

good luck. let us (me) know how you fare.

jeff
Back to top
Guest






PostPosted: Wed Aug 10, 2005    Post subject: Reply with quote

Code:
/[\W\d](onlineads?|ad(banner|click|-?flow|frame|ima?g(es?)?|_id|js|log|serv(er|e)?|stream|_string|s|trix|type|vertisements?|v|vert|xchange)?)[\W\d]/


This is the filter that is being triggered. The subpage that triggers the error should be along the lines of

https: //mail.google dot com/mail/?view=page&name=js&ver=

none of the above should be bad. What you find at the end of the url is likely the cause of your problem. The ver code will show some combination of numbers/letters including the string "ad".
Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group