The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

cannot hit enter to submit forms

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Mon Nov 03, 2003    Post subject: cannot hit enter to submit forms Reply with quote

I just installed the latest build (V0.5 d2 Nightly build 08) of adblock. The shift double click to block images which contain links works great now! But... whenever I enter text into a form and just hit enter, it doesn't submit the form. For example, if i was on google and type in my query into the search box, i used to be able to just hit enter to submit the form. Now i have to click the submit button. This is true for just about any form i've tried. Just to be sure i "de-installed" adblock, and the problem went away.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Mon Nov 03, 2003    Post subject: Reply with quote

At first, this didn't make any sense -- Quickblock only watches mouse-events, so it shouldn't be trapping this.
.
But, after checking the event-details, it became apparent the browser fires a mouse-event -- pretending that you clicked submit. It flags the event as shifted.. which Quickblock then terminates.
.
I've landed a patch, but the browser really shouldn't be doing this. It's kind of playing fast-and-loose.
Back to top
View user's profile Send private message
vitriolix



Joined: 06 Nov 2003
Posts: 1
Location: Berkeley, CA

PostPosted: Thu Nov 06, 2003    Post subject: Reply with quote

oh cool.... i wasjust about to report this one, its the only thing stopping me from using adblock right now. how long til the devel snapshot installer will be synced up with this change?

thanks! Smile
Back to top
View user's profile Send private message Visit poster's website
Glenn



Joined: 06 Nov 2003
Posts: 13
Location: Temple City, CA

PostPosted: Thu Nov 06, 2003    Post subject: Reply with quote

Ah, so that was Adblock-involved, as well..

My brother was experiencing this problem with two of his Netscape installs, while I've not had the same problem in Mozilla and Firebird. Because he had installed many extensions, it was difficult to pinpoint which one in particular was causing the problem.
Back to top
View user's profile Send private message
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Fri Nov 07, 2003    Post subject: Reply with quote

"Landed" means the posted build has been updated. Just so we're all clear.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group