The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Images loaded via @import-referenced external .css files...

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Sun Mar 21, 2004    Post subject: Images loaded via @import-referenced external .css files... Reply with quote

Story with an ad AdBlock can't touch.

Specifically, on my system, I see a 'Hidden Gems' ad, with a background image used to display the graphic for the ad.

This may be beyond the abilities of AdBlock, as digging revealed that they've used a seperate .css stylesheet to load said image as the background.

This appears to mean that even by blocking the image loaded by name, AdBlock can't stop the image frmo loading and being displayed.

Also, trying to block the .css file itself is also fruitless, as it's being loaded via an @import tag inside an existing .css stylesheet integral to the webpage.[/url]
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Mon Mar 22, 2004    Post subject: Reply with quote

Guest:
This blockd it here: http://g.fool.com/art/new/marketing/
.
If it doesn't for you, then describe your setup: build / platform, other extensions, etc.
Back to top
View user's profile Send private message
Guest






PostPosted: Mon Mar 22, 2004    Post subject: Still not blocked. This is odd now... Reply with quote

That ad-string doesn't block the image from loading here.

Platform: Gentoo Linux 2.4.22, compiled up from Stage1 install.
Mozilla FireFox 0.8 from CVS on 20040316, installed to local user directory, not installed system-wide.

.mozconfig:
Code:
ac_add_options --enable-svg
ac_add_options --enable-svg-renderer-libart
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
MOZ_INTERNAL_LIBART_LGPL=1

ac_add_options --disable-composer
ac_add_options --disable-debug
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --disable-tests
ac_add_options --enable-crypto

ac_add_options --enable-extensions=default,-inspector,-irc,-venkman

ac_add_options --enable-optimize="-pipe -Os -march=athlon-mp"

ac_add_options --disable-freetype2
ac_add_options --enable-xft
ac_add_options --enable-default-toolkit=gtk2

mk_add_options MOZ_PHOENIX=1
MOZ_PHOENIX=1


No other extensions are installed except AdBlock (v0.5 d2 Nightly * build 35 installed from the webpage via .XPI file), which is installed to the Mozilla folder, not the Profile directory.
Back to top
MW
Guest





PostPosted: Mon Mar 22, 2004    Post subject: Reply with quote

Works for me...
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Back to top
kstahl
Support


Joined: 02 Jan 2004
Posts: 1202
Location: Stockholm, Sweden

PostPosted: Mon Mar 22, 2004    Post subject: Reply with quote

Does not work for me. I still get that fat cheesy ad in the middle of the page.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040320 Firefox/0.8.0+

I'm running the latest build 36 alpha.
Back to top
View user's profile Send private message
Guest






PostPosted: Mon Mar 22, 2004    Post subject: Reply with quote

kstahl wrote:
Does not work for me. I still get that fat cheesy ad in the middle of the page.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040320 Firefox/0.8.0+

I'm running the latest build 36 alpha.

Ditto for me.
Back to top
MW
Guest





PostPosted: Tue Mar 23, 2004    Post subject: Reply with quote

as i aid before WFM so i'll give my standard diagnosis attempt...lol..... try disabling OBJ-TABS....not sure why it would work here but just in case
Back to top
WolfWings
Guest





PostPosted: Tue Mar 23, 2004    Post subject: Reply with quote

Obj-Tabs isn't enabled. Toggling it doesn't affect the bug. Enabling it doesn't add a tab to that 'ad' either, as it's a background image.

I have noticed that it seems that the other people saying it doesn't work are using a version of FireFox that's 0.8 or later. Could there be some bug in the CVS tree that's breaking compatability with AdBlock in this subtle way?
Back to top
WolfWings
Guest





PostPosted: Tue Mar 23, 2004    Post subject: Reply with quote

And just to verify, I was the 'Guest' that initially posted the bug report, and that posted the first followup as 'Guest' until I noticed I didn't need to register to post with a username. Smile
Back to top
Guest






PostPosted: Tue Mar 23, 2004    Post subject: Reply with quote

WolfWings wrote:
Obj-Tabs isn't enabled. Toggling it doesn't affect the bug. Enabling it doesn't add a tab to that 'ad' either, as it's a background image.

I have noticed that it seems that the other people saying it doesn't work are using a version of FireFox that's 0.8 or later. Could there be some bug in the CVS tree that's breaking compatability with AdBlock in this subtle way?

Ditto for me.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group