The Adblock Project Forum Index The Adblock Project
Pull up a seat ...stay a while.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

AdBlock not blocking images on start page every time

 
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Sat Dec 20, 2003    Post subject: AdBlock not blocking images on start page every time Reply with quote

I'm not exactly sure how to report this as a bug, but I'll try. I have http://my.yahoo.com set as my home page in Firebird ([Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+ (aebrahim)], but it's been happening for quite some time in different builds...don't know if the browser or AdBlock is the problem), and I am currently using the .5 dev release, build 34 (also happened under build 30).

Anyhow, when I load up Firebird, about half the time the big banner on the top of the page isn't blocked. I have "http://us.a1.yimg.com/*" and "http://us.yimg.com/*" set to be blocked, so about 95% of Yahoo's ads get removed for me. If I right-click on the image and select "Adblock image" to see what the address is, nothing comes up. The Adblock notification in the status bar doesn't indicate that anything is blocked, obviously. If I open the image's properties, it states that it comes from one of the two addresses I have set to be blocked.

Now here's the hard part: if I reload the page, the image (or its replacement) is removed. Every time. So it's only on that first page that AdBlock can't seem to block the images, but it's not *every* time I load the first page that the image isn't removed. I'd change my start page to test it on another site, but for some reason Firebird doesn't want to allow that.

Any thoughts? I know it's weird and tough to pin down, but have other people reported not being able to block images on their start page 100% of the time?
Back to top
aoLhaTer



Joined: 26 Nov 2003
Posts: 16

PostPosted: Sat Dec 20, 2003    Post subject: Reply with quote

Use this filter
us.a1.yimg.com/us.yimg.com/a/
that removes all of yahoos advertising but not their normal images
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Dec 20, 2003    Post subject: Reply with quote

aoLhaTer wrote:
Use this filter
us.a1.yimg.com/us.yimg.com/a/
that removes all of yahoos advertising but not their normal images


Well that works nicely to block images when I surf to them (and I switched to that filter instead of my normal ones because the back and forward buttons in the TV listings disappear normally), but the ad banner on http://my.yahoo.com still appears and AdBlock won't bring up the "AdBlock image" context menu on the image when I click it.

I did remember one piece of information--the only images that DON'T appear are Flash ads, because I have Flash Click to View extension installed. I get the "Click for Flash" message on the ad, and when I click it it disappears. It's almost like AdBlock is being loaded after the page is, or something of the sorts, since when I reload or go back to the page no ads appear.
Back to top
Org



Joined: 23 Oct 2003
Posts: 349

PostPosted: Sat Dec 20, 2003    Post subject: Reply with quote

I dare to claim the you don't need the extension "Flash Click to View" at all if you define your Adblock filters well. I checked my filters with the "Adblock-able Items" window and only these two were used on the page my.yahoo.com:

.yimg.com/a/
/^http:\/\/ad([sz]?|images|img)\./

As far as I could see, these filters blocked all the ads but none of the normal images.

(I'm using the Adblock options "Remove ads", "Collapse blocked elements" and "Check parent links".)
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Dec 20, 2003    Post subject: Reply with quote

I use Flash Click to View not for ads, but for sites that HAVE to use Flash to navigate through them. I use to not have Flash even installed and had AdBlock set to kill all *.SWF objects, but it got too hard to get through some sites. AdBlock removes a Flash object coming from a server on my filter list, though.

I'll try your settings and see if it makes a difference somehow.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sat Dec 20, 2003    Post subject: Reply with quote

Guest:

Try removing Flash-Click-To-View.
.
If you're on a dialup or something and can't handle this, try unchecking "Obj-tabs" in Adblock's pref-window options.
Back to top
View user's profile Send private message
Another Guest
Guest





PostPosted: Sun Dec 21, 2003    Post subject: Same problem Reply with quote

I have the exact same problem. It only started after I installed the Shockwave plugin in order to view some sites (I installed Flash and Director at the same time, so not sure which one it was).

The first time, it doesn't block the my.yahoo banner. When I reload, it works fine.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Sun Dec 21, 2003    Post subject: Reply with quote

Another Guest:
You have FCTV installed? And this only occurs when my.yahoo is your startup page?
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Dec 23, 2003    Post subject: Reply with quote

I'm the original Guest. Yeah, I've posted here a few times, but I'm just too lazy to register.

I wish that either MozillaZine or Mozdev would run a central forum for extensions separated by projects. That would be helpful.

Disabling FCTV actually solved the problem. I closed and reloaded Firebird about a half dozen times, and the banner was removed every time. That's sort of weird. I really like having the FCTV extension installed, so I'm not sure what I should do now.
Back to top
Another Guest
Guest





PostPosted: Wed Dec 24, 2003    Post subject: Reply with quote

I'm the original Another Guest, who is not the same as Guest. Smile

I don't have FCTV installed. It only happens on my.yahoo as far as I know. My yahoo block regexps are:

http://*.*[^(news)]*.yimg.com/*
http://*.yimg.com/*swf*
http://us.a1.yimg.com/us.yimg.com/*.gif

I dunno why I added the last one, since the first should've taken care of it, but it might've been in response to this problem, so I added a more specific regexp (I forget).

Anyways, it doesn't ALWAYS happen, but when it does, clicking on "Adblock image" doesn't bring anything up (that's why I figured it was the same problem as the original Guest had). And when it does happen, reloading the page removes the ad. It's very odd (and not a huge deal, since reloading it seems to work fine, but it may be because it uses a different banner on reload, rather than having the reload actually fixing it).

BTW, AdBlock RULES! It's one of the top 3 reasons I use Firebird.
Back to top
Guest






PostPosted: Wed Dec 24, 2003    Post subject: Reply with quote

i don't know regexp, but i do believe that you CAN'T mix wildcards & regexp expressions as you have..... sorry but i am not knowledgable to help further, but maybe that will help.

my yahoo filter is ".yimg.com/a/" (no quotes) and that seems to work on all that i want blocked, but perhaps that is too broad for what u want
Back to top
Guest






PostPosted: Wed Dec 24, 2003    Post subject: Reply with quote

I'm the original Guest.

I disabled FCTV and restarted Firebird a bunch of times and that seemed to fix it, but oddly enough Flash objects still have the "Click to View" label on them and later I noticed my My Yahoo start page still had the ad banner.

I'm going to download a new build when one comes out today and try it without the FCTV extension, see if that works, then I'll get back here and report my findings.
Back to top
rue
Developer


Joined: 22 Oct 2003
Posts: 752

PostPosted: Wed Dec 31, 2003    Post subject: Reply with quote

Original Guest:
Read this whole thread before continuing. Note the heads-up at the end.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Adblock Project Forum Index -> Main All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group